Verifying World 5-1 Sophia 1-up glitch

Discussion in 'Bugs' started by Banana Cream Pie, Sep 2, 2012.

  1. Banana Cream Pie

    Banana Cream Pie Level 0: Newbie

    I was playing SMBC, and in World 5-1 I dscovered a rather interesting bug with Sophia III. I wall-climb on the tower of 4 unbreakable blocks right before the fourth bottomless pit. Sophia's sprite was on the right side of the tower, covering the top two blocks. The cannon of the tank was aimed upward. (note that this makes the front wheel overlap with the invisible block containing a 1up, which is important)

    Anyway,when I shot the invisible 1up block, the block appeared exactly where the tank's front wheel was. Because of this, I found myself stuck and unable to move. I was able to destroy the bricks to my right, but no movement. I tried to jump, but was pushed through the towerand found myself clinging to an invisible vertical wall. Sophia can go up and down the wall, or jump off. The tank is a lot more slippery on this wall than normal, while pressing the jump button again would cause Sophia III to hover. (I managed to replicate this several times; it seems like the bottom wheel has to touch the top block)

    I'm not sure if all that was clear or not... :)

    One last thing: Not all graphics will shor the tower of four blocks (it might be represented as a solid tower. Just to make sure that Sophia III is on the right blocks, I suggest SMB1 NES, SMB1 SNES, SMB3, or Demon Returns graphics)
     
    Anders Chirstensen likes this.
  2. Rey D

    Rey D Level 12: Super Mod
    Patron

    I kind of see what you mean.
    Can you provide a few screenshots? It would help making your report more obvious.
     
  3. Payday4515

    Payday4515 Level 1: Goomba

    I tried it out and it actually happens. I got stuck on the tower and it shot me into the bottomless pit. But luckily I had the bouncy pits on. Lol
     

Share This Page